How to Build a Computer

So, you want to build a computer. There are a lot of good reasons to build your own computer.

Building a computer can be both rewarding and challenging. It can also be a learning experience. Some reasons you may want to build your own computer may be:

  • To save money
  • To build something to your exact specifications
  • To learn how it’s done

Often building your own computer can save you money. You do not have to pay for someone else to assemble your computer because you can do it yourself. You are bypassing the middleman. Also, you may be able to buy the components cheaper than other companies can get them. Some computer parts may even be given to you. Or you might reuse parts of an existing computer. Any of these can save you money.

If you have very specific ideas of what you want your computer to do, you may have requirements that a pre-built computer is not likely to meet. For instance, you may want a computer to run a particular business program and so you have looked up the requirements for that program. You discover you will need a lot of RAM, but not a particularly fast processor and even a simpler graphics card. When you search for a computer with a lot of RAM, only high end gaming machines come up which is nothing like what you want.

Or maybe you do want a gaming machine, but you already know which GPU you want to include, how much RAM you want, and even how cool the case will look. To get these exact specifications you need to build it yourself.

Another reason to build your own computer is to know how it is done. Computer have a fascination for many of us and there is something rewarding in getting your hands into the inner workings of one of your own. There may be certain bragging rights involved as well.

Note:

One thing to keep in mind if all this seems overwhelming. There may be some parts of the process where caution is needed, but most parts of the computer have only one place where they can fit. Your memory cannot fit where a PCI slot is located, and a hard drive cable cannot fit into the power connection.

Now let’s get started!


Supplies Needed

Here are the supplies you should get before starting this project. Some of these you cannot do without and some are optional.

  • Phillips screwdriver
  • Phillips screws
  • Motherboard standoffs (spacers)
  • Anti-static strap
  • Various cables
  • Clean, well-lit place to work
  • Access to a Windows OS installation CD/DVD, or download

Let me quickly explain the use of each of these:

The Phillips screwdriver is the most indispensable tool you will use as you build your new computer. Almost every component you assemble will require it as most are put together with screws. If you don’t have one, buy a #2 Phillips head screwdriver. You may also use other sizes for some assembly, but #2 will likely be the one you use most.

Note:

If you can get one, use a magnetic screwdriver. There is nothing more aggravating than having your screw fall down into the case and hide behind tightly assembled components.

Let’s talk about the screws. You will want a collection of small Phillips screws. There is more than one size and threading you can use, but keep a variety on hand for the assembly.

Motherboard spacers are small, usually plastic, pieces (see picture above) that keep the motherboard from touching the metal of the case. This keeps the electronics from shorting out or causing other electronic damage. Standoffs can be used as well, which screw into the case, keeping the motherboard from touching.

There is a bit of debate about anti-static straps. The anti-static strap, shown in the figure above, is used to protect your computer parts from static electricity. Static electricity can destroy many of the more sensitive computer parts and must be avoided at all costs. To use the strap, wrap tie Velcro section around your wrist and then clamp the alligator clip to anywhere on the metal computer case. This keeps you grounded.

Many people don’t use this strap. If you choose not to, follow these safety precautions:

  1. Touch the metal computer case before installing anything in the case.
  2. Do not work on a carpet, since carpets are good generators of static electricity.

One last thing you need in order to work safely on your computer-a clean, well-lit place to work. Clean, because dust can destroy computer parts. So maybe the garage is not the best place to work on this project unless you first clean up your workspace beforehand.

Make sure you have lots of light. It is often hard to see what is going inside the case as you attempt to plug in certain components or find the holes for the screws. If you have access to a swinging arm desk lamp, that will make things easier. A good flashlight might come in handy as well.

While it is possible to do this work on a clean floor (remember, no carpet), it might be more comfortable if you can do it on a desk. Clean it off so you don’t loose screws or get dust in your computer.


Choosing a Case

Pick a case that fits the kind of computer you want in the end.

Often people start by choosing a case. There is quite a wide variety of cases out there, from the fancy gaming cases, often liquid cooled and with led lights of several colors, to the basic box. Keep in mind that the case and the motherboard go hand in hand, so you may opt to start there and choose a case second.

Some things to keep in mind when selecting a case for your computer:

  • It needs to be large enough for everything you intend to add
  • Look for one with a good power supply and fan
  • How you want it to look

The size of your case must fit with its planned use. If you want a case for four hard drives and a DVD drive, you need space for all of that. There are places where these must go, and the average case only has room for two or three hard drives. The size of the case also relates to the size of the motherboard you want to use. See the motherboard section if you want to start there.

For someone building their first computer, it is recommended you buy one with a built in power supply and fan. Again, the motherboard and graphics card will have certain power requirements, so if you are building a high performance or gaming machine, chose those before you select your case with power supply. If a power supply comes with your case, a fan is almost always a part of it as well.

Note:

There are several fans that go into a computer. A power supply fan, a CPU fan, maybe a graphics card fan, and perhaps one or more case fans.

The look of your case may also be an important factor. For many, this computer will an important part of your living room, office, or bedroom. Do you want it to look professional? Fun? Do you want it to blend in to the surroundings or stand out?

Note: From here on out we will get into not only selecting parts, but installing them.


Choosing Your Motherboard

Here are the basic motherboard types (form factors). Select carefully since this is one part of the computer you will not be able to upgrade later.

There are only three motherboard form factors you will likely come across. The ATX, MicroATX, and Mini-ITX.

Note:

There are others but they are less common and not as useful for our purpose

Keep in mind that different motherboard form factors are meant to fit into certain cases. The first rule is that the case cannot be smaller than the motherboard. Also, you will see holes for screws in your motherboard and correlating holes in the case. Often a case will be able to accommodate more than one form factor, however. Therefore it will have more holes than you need for your motherboard.

Let’s take a closer look at what is on a motherboard:

The CPU socket is where you put the CPU. This is your computer’s “brain” and is often one of the more expensive pieces to buy. It is square and has many pins which fit into the small holes as it is placed firmly in the motherboard.

You will have anywhere from two to eight RAM slots. Make sure your motherboard can accommodate the amount of RAM you want if you plan to do a lot of video production, gaming, or certain business software. Also keep in mind there are different types of RAM, so you will need to read the manual that came with your motherboard to make sure you get the right kind.

PCI slotscome in several types, but they are a fast connection for many cards, such as networking, sound, and sometimes video. Make sure you have enough for what you want to add to your computer.

At the top of the diagram, you will see a black floppy disk port (something few people add anymore) and two EIDE ports. Here you plug in your hard drives. The motherboard above can take up to two hard drives. Some can take many more.

Note:

Just because your motherboard has room for two hard drives does not mean your case has a place for them. For such reasons some people buy a barebones setup where the motherboard is already installed and there is no guess work.

Finally we have the I/O ports. In the motherboard above, you get mouse and keyboard connections (mostly an old style), two USB ports, and a printer port. For your convenience these have been built into this motherboard, but that is not always the case. Sometimes more PCI cards must be bought to fill these needs. Some motherboards even have built-in video.

Note:

You may have noticed a large black slot on the far right. You will seldom find this on modern motherboards. It is called an ISA slot. Mostly PCI slots have replaced this outdated feature.

  • Motherboard Installation
    Here are the basics for installing a motherboard


Motherboard Installation

Here are the basics for installing a motherboard

  1. Open your case (usually using your screwdriver), and take a look inside.

  2. Screw your standoffs into your case if you have them. If using plastic spacers instead, put screws through the appropriate holes in your motherboard and then through the spacers.
  3. Sometimes you have to remove an I/O panel shield before you can fit the motherboard inside. If you put your motherboard in and see a place where your I/O ports should stick out of the case, remove the small metal panel and try again.
  4. Place the motherboard inside the case and use your screws to fasten it in place. Use your Phillips to tighten it.
  5. Connect the power supply. This is a set of wires ending in a connector that comes from the power supply. Find the corresponding plug on your motherboard and connect it. You may not have access to this after other parts are connected so make sure this comes first.
Parent topic: Choosing Your Motherboard


Choosing Memory

When choosing memory for your new computer, keep these things in mind.

RAM (Random Access Memory) is easy to install, but may be harder to choose. When selecting the memory you want, ask yourself these questions:
  • What is compatible with my motherboard?
  • How much memory do you need?
  • How fast do you need your memory to be?

When you bought your motherboard, it came with a manual. Search through that manual to find out what kind of RAM will work for your computer. If you are reusing an old motherboard and you no longer have a manual, you can easily search the Internet for the information you need.

Every motherboard has the model number and other identifiable information printed on it. You can do a search for your model and find out the specifications, revealing what kind of RAM it requires.

The amount of memory you want will depend on it’s usage. If you plan to use your computer for high-end games or video editing, more is usually better. Web browsing can use a lot of RAM by itself.

8GB is good for most things on Windows.

There are also different speeds when it comes to RAM. This number can usually be seen in the label itself. As an example, DDR3-1600 means it is the 3rd generation of DDR (a newer type of ram), and that the speed it 1600 MT/s. That means it can perform 1600 megatransfers per second. Therefore DDR3-1600 is slower than DDR3-1866. Again, research what applications you will be running to determine how much speed will make a difference.

Note:

Keep in mind, you can always upgrade your memory later if you want.

  • Installing Memory
    Now you will install the memory for your computer


Installing Memory

Now you will install the memory for your computer

  1. Touch your hand to the metal of your computer case if you are not using an anti-static strap.
  2. Look in your case with the installed motherboard and find the memory slots. There will often be anywhere from 2-6 slots.
  3. Push back the wings (small tabs on each side of the memory slot).
  4. Firmly insert the memory into the slots provided. You will have to line up the notches correctly for this to work. This means you can only insert it one way.
  5. Sometimes you will have to apply pressure to one side of the RAM at a time to get it into the slot. Then push on the other side until it fits snugly.
  6. Push back the wings so that they click in place.
Parent topic: Choosing Memory


Buying a DVD Drive

If you decide to install a DVD drive, here are some things to consider.

These days, a CD-ROM or DVD drives in a computer are less of a necessity than they used to be. Now most software can be downloaded from the Internet and music is listened to the same way. There are some good reasons still to own a DVD or CD-ROM drive, however.

  • You want to backup videos or pictures from your drive
  • You own software on a DV D or CD and you want to install or run it
  • You produce music that you want to burn to a CD
Whatever the reason, DVD or CD-ROM drives are inexpensive and most computer cases provide space for them to be installed. Here’s what to look for:
  • Is it for DVD or CD or both?
  • Does it only read or also burn (write) to disk?
  • If a DVD burner, does it also work with blu-ray? How about 4K?
  • How fast does it read? How fast does it write?
  • How dependable is it?

If you only intend to read or write CDs, you only need a CD-ROM or CD-RW (Read/Write) drive. If you want to read DVDs, which hold a lot more information, get a DVD drive. Keep in mind that these drives are very inexpensive, so there is little reason to hold back from getting a DVD-RW. Even blu-ray drives do not cost too much.

If you want to read or write to 4k the price increases. This is a relatively new technology and the cost reflects that.

The speed of the drive becomes important especially when burning (writing) your own discs. There is a wide range of writing speeds, so burning a disc could take anywhere from a few minutes to an hour or more. Keep in mind that larger capacity discs, such as blu-ray or 4k will take longer than DVDs or CD.

The dependability of the drive is also important especially when it comes to burning discs. A burner that is not dependable may often have errors when burning and so the disc does not work. This can also make producing a viable CD, DVD, blu-ray, or 4K disc time consuming. Check ratings for the drive by testers or customers before buying if this is important to you.


Buying a Hard Drive

A few things must be considered when purchasing a hard drive for your computer.

  • Size (dimensions)
  • Type (solid state vs traditional)
  • Capacity
  • Speed

The very first thing to consider for a hard drive is what your case and motherboard will support. The case has drive bays (holding spaces) made for certain types of hard drives. The larger bay is for a traditional drive, while a smaller bay can hold a solid state drive. Many have an area for both.

There are two main types of hard drives to consider: solid state and traditional. Solid state drives are faster to save information and read it off the disk, and they use less power. If you want the fastest machine possible, this is the drive you want. The operating system will boot faster, games will work faster, and you will spend less time waiting for programs to open.

There is one drawbacks to solid state drives, however. They are far more expensive than traditional drives for the same capacity.

After you have selected the type, you should consider the capacity. If you only intend to use your computer to surf the Internet and do some basic word processing, then you only need enough for the operating system and some basic software.

For Windows, a good starting size for such basic applications can be as small as 25 GB.

Note:

The standard traditional hard drive speed is 7200 RPMs (Rotations Per Minute), but some go as high as 15000 RPMs. Traditional drives can have a transfer rate speed of 50-120 MB/s (megabytes per second) Of course, the fastest drives are still solid state drives that regularly have between 200-500 MB/s.

Note:

While in theory there are different types of interfaces (with different cables) to connect the motherboard to your hard drives, about 99% of them are SATA. If for some reason you have another connector type, there are adapters to you buy to fit your situation.

  • Hard Drive and CD/DVD Drive Installation
    With the proper tools, a hard drive can be installed in a couple of minutes


Hard Drive and CD/DVD Drive Installation

With the proper tools, a hard drive can be installed in a couple of minutes

  1. First put the hard drive into the proper drive bay inside your case. Sometimes this is trick as they made a tight fit, but put it in so that the holes line up for the screws.
  2. Add any additional drives, including any CD-ROM you may want to include. Make sure everything fits and you know where you want everything to go.
  3. Now you may need to remove the other drives in order to install them one-by-one.
  4. Once the holes are aligned, screw in enough so the drive will be secure. Do not use long screws. You do not want to damage the inside of the drive.

  5. Put each drive in and secure it with screws one at a time until done. Some types of drives require a power supply separate from the SATA and some use power from the SATA cable itself. If a hard drive or CD-ROM has a power input, run a power cable from your motherboard and plug it into the drive. Also, if your motherboard does not support SATA, you may need an adapter for SATA drives.
  6. For each one, take the SATA cable (which probably came with the drive), and connect one end to the motherboard and the other end to the drive.
Parent topic: Buying a Hard Drive


Choosing a Video Card

You may or may not need a video card. If you do, keep these considerations in mind.

If the motherboard you selected has a built-in video card, then you do not require a video card. If you do not, then you will need one. Here are some questions that will narrow down the search:

  • Do you intend to use this computer for intense gaming?
  • Do you plan to use it to edit video?
  • Will you be doing photo editing or graphic design with this computer?
If you plan to do none of these things, then most graphics cards will do well for you. Such cards do not cost much and they use little power.

If you do plan to do one of those activities listed above, consider a higher end graphics card (GPU). There are really two main players in this field: Nvidia and AMD. There is a lot written about the fierce competition and unique specifications for graphics cards. Do your homework in this area before selecting your graphics card.

Also make sure your motherboard can support it. Most computers use a PCI slot for the graphics card, but some older motherboards still use an AGP slot. PCI offers a faster connection.

Also make sure it can run the specific programs you want. You software documentation or even an Online search will give you these requirements.

  • Installing a Graphics Card
    Graphics card installation is a snap. Here is how you do it.


Installing a Graphics Card

Graphics card installation is a snap. Here is how you do it.

  1. First put on your anti-static strap or touch the metal computer case before starting.
  2. The interface for a graphics card is a either an AGP (older) or PCI. Find the slot where your graphics card fits.
  3. Make sure to remove the I/O shield (making it accessible to plug into when closing up the case)
  4. Insert the graphics card, pushing firmly on one side at a time and then working your way to the other side. That’s all there is to it!
Parent topic: Choosing a Video Card


Choosing a Network Adapter

If your motherboard didn’t come with a network adapter, here are several features to consider when buying one.

Network adapters are inexpensive, but important to have in your computer. Here are some possible features to consider when buying one:

  • Is a NIC (Network Interface Card) already a part of my motherboard?
  • How fast is the wired connection?
  • Does it include wireless? What kind and how fast is the wireless?
  • Does it include bluetooth? What specification?

Most motherboards already come with a network card built in. If that is the case, you are good to go. If not you should buy one. Fortunately they don’t cost much.

There are two features on most network adapters: A wired Ethernet connection and wireless. If you are close to your Internet source, make sure you have an Ethernet port. This way you will never have an issue if your wireless is malfunctioning.

If you need wireless to connect your computer, make sure the feature is a part of the network card you buy. There are different speeds and specifications for wireless, so make sure you get what will work well for you.

Some network adapters include bluetooth. These can be useful, but buying a separate USB bluetooth adapter is very cheap, so no need to make this a reason to buy one card over another.

  • Installing a Network Adapter
    Installing a network adapter only takes a minute. If your motherboard does not have one already included, follow these steps to install one.


Installing a Network Adapter

Installing a network adapter only takes a minute. If your motherboard does not have one already included, follow these steps to install one.

  1. Put on your anti-static strap or touch the metal computer case before starting.
  2. Find an open PCI slot in your computer.
  3. Remove any I/O shield in place so you will have access to it once the case is closed.
  4. Insert the network card, pushing firmly on one side and then working your way to the other side.
  5. If you have an antenna for wireless that came with the network card, screw it in at the end.
Parent topic: Choosing a Network Adapter


Choosing a Sound Card

If your motherboard does not come with a built-in sound card, use these guidelines when buying one.

  • Do you have games that you want to play where sound quality is important to you?
  • Does your computer double as your TV and you want 7.1 sound for your movies?
  • Do you plan to use your computer for music production?

If you do not plan to use your computer in the above ways, you will probably be able to use a simple sound card. These cost very little.

If you need a high-end sound card, do your research. Just like graphics cards, there is a lot of competition in the realm of technology. They can include stereo, 5.1 or 7.1 surround sound. Some have ports for a subwoofer and numerous speakers and other possible connections.

  • Installing a Sound Card
    Follow these steps to install your sound card


Installing a Sound Card

Follow these steps to install your sound card

  1. Put on your anti-static strap or touch the metal case of the computer.
  2. Find an open PCI slot on your computer.
  3. Remove the I/O shield so you will have access to the card once the computer is all put together.
  4. Insert the sound card, pushing on one end first and then moving your way to the other side.
Parent topic: Choosing a Sound Card


Choosing a USB Card

If your motherboard and none of your other cards included USB connections, you should buy a USB card.

If you need to buy a USB card, keep these options in mind:

  • How many ports do you need?
  • What is the transfer speed you need?

The number of ports is both important and not important. It is true you may need many ports available to plug in your keyboard, mouse, printer, an external hard drive, and other hardware. The reason that may not matter too much is because you can buy an adapter that will turn one USB connection into many. It is easy though to find USB cards with many connections and the cost is cheap.

One thing you may want to consider is how fast the USB ports go. USB 2.0 ports transfer speed at 480 megabits per second, whereas USB 3.0 ports transfer at 5 gigabits per second. This is an impressive difference, but seldom to people need something that fast. If speed is important to you, make sure to buy accordingly.

  • Installing a USB Card
    Installing a USB card is as easy as other cards. All you need is an open PCI slot. Here is how you do it.


Installing a USB Card

Installing a USB card is as easy as other cards. All you need is an open PCI slot. Here is how you do it.

  1. Put on your anti-static strap or touch the metal case of the computer.
  2. Find an open PCI slot on your computer.
  3. Remove the I/O shield so you will have access to the card once the computer is all put together.
  4. Insert the USB card, pushing on one end first and then moving your way to the other side.
Parent topic: Choosing a USB Card


Finishing Up

Your computer is just about done. Here is what you need to do to finish up.

  1. If you have any other cards or devices to install, do that.
  2. Make sure hard drives and CD/DVD drives are screwed in correctly.
  3. Make sure all devices are connected with the correct cables and they all fit snugly.
  4. Put your case back together with the correct screws.
  5. Install your Windows OS and any other software you want on your new computer.
  6. Bask in the fact that you just built your own computer!